Quitando Gimp-2.7.2 y volviendo al Gimp 2.6

Esperando como muchos que Gimp 2.8 pueda estar entre nosotros, decidi probar y usar por un tiempo el Gimp 2.7.2 mas que todo por las barras de herramientas de los lados ya empotradas en una misma y unica ventana y no flotante como aun Gimp 2.6.X ofrece. Asi que decidi un dia subir un poco de nivel y pasarme al Gimp-2.7.2 (lo cual me arrepiento ahora y lo cual volvi al 2.6).

Estuve un tiempo usando el Gimp 2.7.2 y parece estar todo bien hata que realice una accion de Filtros – Luces y sombras – Sombra arrojada y sucedio esto, lo cual comenta de unos archivos desactualizados aun en uso y que debia cambiar por otros lo cual realment eno sabia como y Google solo me arrojaba un solo link que no ofrecia solucion alguna.

Asi que decidi volver a la version que tenia antes, pero cuando desintale Gimp 2.7.2 tuve un par de problemas para tenerlo nuevamente como antes, ya que al volverlo a instalar volvia a ser el Gimp 2.7.2 por lo que acudi al IRC canal ubuntu-es donde unos buenos amigos que en muchos casos estan alli para ayudar (mimecar, dzup, miniminiyo, dabor, cous.. no recuerdo bien el nick de este ultimo) me ayudaron.  Borre los dos PPA que tenia en Synaptic que abrimos desde Sistema->Administracion->Gestor de Paquetes Synaptic y en este vamos a Configuracion->Repositorios y en la ventana a la pestana “Otro Software” y eliminamos los PPA que digan gimp (pero yo aconseo mejor destildarlo en vez de borrarlo).

Luego desintale Gimp 2.7.2 desde la terminal realiza lo siguiente:

sudo apt-get remove gimp

sudo apt-get purge gimp

sudo apt-get clean

sudo apt-get update

sudo apt-get install gimp

Pero al intentar instalarlo me dio este error:

jose@asus:~$ sudo apt-get install gimp
Leyendo lista de paquetes... Hecho
Creando árbol de dependencias
Leyendo la información de estado... Hecho
No se pudieron instalar algunos paquetes. Esto puede significar que
usted pidió una situación imposible o, si está usando la distribución
inestable, que algunos paquetes necesarios no han sido creados o han
sido movidos fuera de Incoming.
La siguiente información puede ayudar a resolver la situación:

Los siguientes paquetes tienen dependencias incumplidas:
 gimp : Depende: libgimp2.0 (<= 2.6.10-z) pero 2.7.3-2011021801~mm va a ser instalado
        Depende: gimp-data (<= 2.6.10-z) pero 2.7.3-2011021801~mm va a ser instalado
E: Paquetes rotos

Asi que desintale esos paquetes tambien:

sudo apt-get remove libgimp2.0

sudo apt-get remove gimp-data

Luego volvi a intentar instalarlo, lo cual para este segundo intento si se instalo, pero al intentar cargarlo desde la terminal (ya que me encontraba en esta) me dio otro error:

jose@asus:~$ gimp
gimp: error while loading shared libraries: libgegl-0.0.so.0: cannot open shared object file: No such file or directory

Entre Google y aun en el IRC de ubuntu-es al parecer Gimp tiene dependencia con las librerias babl y gegl las cuales procedi a instalar

sudo apt-get install libbabl-0-0-0

sudo apt-get install libgegl-0-0-0

Realmente no se si era correcto estos o si debia colocar libgegl-0-0.so.0 pero el caso es que ya esas fueron las que use y al intentar desde la terminal volver a cargar a Gimp, funciono. Cuando instale estos archivos/librerias al parecer me desintala el Gimp porque al intentar cargarlo el sistema me indicaba que no estaba instalado asi que luego de instalar estas librerias y volver a instalar Gimp 2.6 para esta ocasion si cargo sin problemas, asi que lo coloque nuevamente en el Menu y en mi barra superior donde tengo iconos de acceso rapido a las aplicaciones que mas abro.

Por cierto, algo masoquista la presentacion de Gimp 2.7.2 comparando con la ya acostumbrada de Gimp 2.6 cierto!?




Y no olvides pasar por TodoGimp donde encontraras muchos tutoriales para hacer muchas cosas en Gimp.


About this entry