GIMP 2.7.1

Normalmente un usuario Linux prefiere que las aplicaciones que coexisten con el sistema vengan de los repositorios, ya que esto garantiza la seguridad que no perjudicara otras partes del sistema y que dicho programa es estable para su uso.  Mientras se espera del GIMP 2.8, en la web de GIMP ya esta el 2.7.0 y 2.7.1 pero en los repositorios aun sigue estando el 2.6.7. Aqui indico un script que encontre y lo cual nos permitira darle una ojeada a la evolucion actual del Gimp camino a su version 2.8 y futuras.

Aconsejo leer este nuevo post antes de proceguir con este, ya que una instalacion de Gimp 2.7.2 resulto ser inestable: Quitando Gimp-2.7.2 y volviendo a colocar Gimp-2.6

El Gimp 2.6.7 me ha dado un problema que cuelga incluso, todo mi sistema, no parece ser un bug, ya que en un ubuntu kk 9.10 virtualizado parece no suceder esto. Este mal percance me hizo probar el Gimp 2.7.1 el cual no se recomienda para desarrollo.

Sin tener que desintalar el Gimp-2.6.7, en paralelo a este bien podemos instalarse el Gimp-2.7.1 por si se desea manejar un poco el Gimp mas acercado al esperado Gimp-2.8 que desde hace ya un buen tiempo se menciona.

Buscando, encontre este articulo sobre un buen script que nos instala de una, el Gimp-2.7.1, que funciona muy bien para Ubuntu 9.04 y 9.10 (no se que tal con otras distribuciones), tarda su buen y largo rato pero al final, lo tendremos en /opt/gimp-2.7/bin/gimp-2.7 para colocarlo (si se prefiere) en el menu donde tenemos las demas aplicaciones graficas, incluyendo al Gimp-2.6.7 que es el que viene instalado con el sistema Ubuntu Karmic Koala 9.10 mientras se espera al 10.4 retocado en su UI al estilo Mac.

Este es el script del sitio que ya he comentado en el parrafo anterior, en caso de quien no maneje bien esto de los script, copia y pega esto en el block de notas gedit o el que uses, guardalo con extension .sh (por ejemplo gimp27.sh) y desde la terminal puedes ejecutarlo de la siguiente forma: sudo sh gimp27.sh

# (as non-root user)

cd ~
mkdir -p tmp
cd tmp

# Important! These variables have to be set and
# are required for all further commands. If you close the
# terminal window, you have to give the 3 export commands
# again.
export PATH=$PATH:/opt/gimp-2.7/bin
export PKG_CONFIG_PATH=/opt/gimp-2.7/lib/pkgconfig
export LD_LIBRARY_PATH=/opt/gimp-2.7/lib

# Fetch the most important packages
sudo apt-get build-dep gimp

# Additional packages
sudo aptitude install checkinstall git-core libtool libopenexr-dev libopenraw-dev libspiro-dev

### BEGIN: ONLY NEEDED FOR UBUNTU 9.04 ###
# Fetch, compile, install Glib (needed for Gtk)
wget http://ftp.gnome.org/pub/gnome/sources/glib/2.22/glib-2.22.2.tar.bz2
tar -xjf glib-2.22.2.tar.bz2
cd glib-2.22.2
./configure --prefix=/opt/gimp-2.7
make -j3
sudo make install -j3
cd ..

# Fetch, compile, install Gtk
wget http://ftp.gnome.org/pub/gnome/sources/gtk+/2.18/gtk+-2.18.2.tar.bz2
tar -xjf gtk+-2.18.2.tar.bz2
cd gtk+-2.18.2
./configure --prefix=/opt/gimp-2.7
make -j3
sudo make install -j3
cd ..
### END: ONLY NEEDED FOR UBUNTU 9.04 ###

# Fetch, compile, install BABL
git clone --depth 1 git://git.gnome.org/babl
cd babl
./autogen.sh --prefix=/opt/gimp-2.7
make -j3
sudo make install -j3
cd ..

# Fetch, compile, install GEGL
git clone --depth 1 git://git.gnome.org/gegl
cd gegl
./autogen.sh --prefix=/opt/gimp-2.7 --disable-gtk-doc
make -j3
sudo make install -j3
cd ..

# Fetch, compile, install GIMP
git clone --depth 1 git://git.gnome.org/gimp
cd gimp
./autogen.sh --prefix=/opt/gimp-2.7 --disable-gtk-doc
make -j3
sudo make install -j3
cd ..

Como decia, eso se llevara un buen y largo rato haciendo lo suyo, y a la final tendremos al Gimp 2.7.1 listo para probar y asi ver como van las cosas con su evolucion. Al menos el Gimp 2.7.1 no me cuelga todo el sistema como el Gimp 2.6.7, razon por la cual lo he instalado.

La ruta del archivo que lo ejecuta es esta: /opt/gimp-2.7/bin/gimp-2.7


About this entry